给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest....
这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
代码实现:
import java.io.*;
/**
* @author yx
* @date 2022-07-20 13:11
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
char[] ss=ins.readLine().toCharArray();
int n=ss.length;
int P=0;
int A=0;
int T=0;
int e=0;
int s=0;
int t=0;
for (int i = 0; i < n; i++) {
if(ss[i]=='P'){
P++;
}else if(ss[i]=='A'){
A++;
}else if(ss[i]=='T'){
T++;
}else if(ss[i]=='e'){
e++;
}else if(ss[i]=='s'){
s++;
}else if(ss[i]=='t'){
t++;
}
}
while (P!=0||A!=0||T!=0||e!=0||s!=0||t!=0){
if(P!=0){
System.out.print("P");
P--;
}
if(A!=0){
System.out.print("A");
A--;
}
if(T!=0){
System.out.print("T");
T--;
}
if(e!=0){
System.out.print("e");
e--;
}
if(s!=0){
System.out.print("s");
s--;
}
if(t!=0){
System.out.print("t");
t--;
}
}
}
}